aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1c1318..287d457 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,17 @@ add_executable(${PROJECT_NAME}
src/terrain.cpp
src/entity.cpp)
-target_link_libraries(${PROJECT_NAME} raylib m pthread dl)
+target_link_libraries(${PROJECT_NAME}
+ raylib
+ m
+ pthread
+ dl
+)
+
+target_compile_options(${PROJECT_NAME}
+ PRIVATE "-O3"
+ PRIVATE "-march=native"
+)
# Checks if OSX and links appropriate frameworks (only required on MacOS)
if (APPLE)