aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsalaaad2 <arthurdurant263@gmail.com>2022-06-11 23:00:10 +0200
committersalaaad2 <arthurdurant263@gmail.com>2022-06-11 23:00:10 +0200
commit5184e532f5c5cd5b6fba52baf5279f3efce08488 (patch)
treeaa5348dd7e6eb44c24a527f6b36c149908a379ec /CMakeLists.txt
parentformat (diff)
downloadyabs-5184e532f5c5cd5b6fba52baf5279f3efce08488.tar.gz
yabs-5184e532f5c5cd5b6fba52baf5279f3efce08488.tar.bz2
yabs-5184e532f5c5cd5b6fba52baf5279f3efce08488.tar.xz
yabs-5184e532f5c5cd5b6fba52baf5279f3efce08488.tar.zst
yabs-5184e532f5c5cd5b6fba52baf5279f3efce08488.zip
set clang++ and fix build issue
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9429c52..0ba14f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,7 @@ project(shooter)
find_package(raylib 3.0 REQUIRED) # Requires at least version 3.0
set (CMAKE_CXX_STANDARD 17)
+set (CMAKE_CXX_COMPILER /usr/lib64/ccache/clang++)
add_executable(${PROJECT_NAME}
src/yabs_core.cpp
@@ -20,6 +21,7 @@ target_compile_options(${PROJECT_NAME}
PRIVATE "-O3"
PRIVATE "-march=native"
PRIVATE "-Wall"
+ PRIVATE "-glldb"
)
# Checks if OSX and links appropriate frameworks (only required on MacOS)