aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsalaaad2 <arthurdurant263@gmail.com>2022-05-27 16:26:01 +0200
committersalaaad2 <arthurdurant263@gmail.com>2022-05-27 16:26:01 +0200
commit8dc03eedfcf24be94f0255c0c9e055dbb83ea092 (patch)
tree4b032f5b17df8da8acb2e41de99afc78a3bcebe2 /CMakeLists.txt
parentupdate readme (diff)
downloadthreshold-8dc03eedfcf24be94f0255c0c9e055dbb83ea092.tar.gz
threshold-8dc03eedfcf24be94f0255c0c9e055dbb83ea092.tar.bz2
threshold-8dc03eedfcf24be94f0255c0c9e055dbb83ea092.tar.xz
threshold-8dc03eedfcf24be94f0255c0c9e055dbb83ea092.tar.zst
threshold-8dc03eedfcf24be94f0255c0c9e055dbb83ea092.zip
less leaks and effective-c++-compatible
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1c1318..287d457 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,17 @@ add_executable(${PROJECT_NAME}
src/terrain.cpp
src/entity.cpp)
-target_link_libraries(${PROJECT_NAME} raylib m pthread dl)
+target_link_libraries(${PROJECT_NAME}
+ raylib
+ m
+ pthread
+ dl
+)
+
+target_compile_options(${PROJECT_NAME}
+ PRIVATE "-O3"
+ PRIVATE "-march=native"
+)
# Checks if OSX and links appropriate frameworks (only required on MacOS)
if (APPLE)