aboutsummaryrefslogtreecommitdiffstats
path: root/raylib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'raylib/CMakeLists.txt')
-rwxr-xr-xraylib/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/raylib/CMakeLists.txt b/raylib/CMakeLists.txt
new file mode 100755
index 0000000..4d06fb8
--- /dev/null
+++ b/raylib/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 3.0)
+project(raylib)
+
+# Directory for easier includes
+# Anywhere you see include(...) you can check <root>/cmake for that file
+set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
+
+# RAYLIB_IS_MAIN determines whether the project is being used from root
+# or if it is added as a dependency (through add_subdirectory for example).
+if ("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
+ set(RAYLIB_IS_MAIN TRUE)
+else()
+ set(RAYLIB_IS_MAIN FALSE)
+endif()
+
+# Sets compiler flags and language standard
+include(CompilerFlags)
+
+# Registers build options that are exposed to cmake
+include(CMakeOptions.txt)
+
+# Enforces a few environment and compiler configurations
+include(BuildOptions)
+
+# Main sources directory (the second parameter sets the output directory name to raylib)
+add_subdirectory(src raylib)
+
+enable_testing()