aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a2edc8..8af6e9c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,11 @@ add_executable(${PROJECT_NAME}
target_link_libraries(${PROJECT_NAME} ${SDL2_LIBRARIES})
+target_compile_options(${PROJECT_NAME}
+ PRIVATE -O3
+ PRIVATE -march=native
+)
+
# Checks if OSX and links appropriate frameworks (only required on MacOS)
if (APPLE)
target_link_libraries(${PROJECT_NAME} "-framework IOKit")