aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..2228b39
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 3.15)
+project(wip-shooter)
+
+find_package(SDL2 REQUIRED) # Requires at least version 3.0
+include_directories(${SDL2_INCLUDE_DIRS})
+
+set(CMAKE_C_STANDARD 11) # Requires C11 standard
+
+set (CMAKE_CXX_STANDARD 17)
+
+add_executable(${PROJECT_NAME}
+ src/city.c)
+
+target_link_libraries(${PROJECT_NAME} ${SDL2_LIBRARIES})
+
+# Checks if OSX and links appropriate frameworks (only required on MacOS)
+if (APPLE)
+ target_link_libraries(${PROJECT_NAME} "-framework IOKit")
+ target_link_libraries(${PROJECT_NAME} "-framework Cocoa")
+ target_link_libraries(${PROJECT_NAME} "-framework OpenGL")
+endif()