aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsalaaad2 <arthurdurant263@gmail.com>2022-05-21 19:24:27 +0200
committersalaaad2 <arthurdurant263@gmail.com>2022-05-21 19:24:27 +0200
commit027634ee9094840adaebf9027d03be0e739ea54b (patch)
treea2c76042fa1e5c3fe757c77d13a3eabc95990384 /CMakeLists.txt
parentfirst test: city (diff)
downloadyabs-027634ee9094840adaebf9027d03be0e739ea54b.tar.gz
yabs-027634ee9094840adaebf9027d03be0e739ea54b.tar.bz2
yabs-027634ee9094840adaebf9027d03be0e739ea54b.tar.xz
yabs-027634ee9094840adaebf9027d03be0e739ea54b.tar.zst
yabs-027634ee9094840adaebf9027d03be0e739ea54b.zip
+addED level
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2228b39..b12ff73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,12 +4,18 @@ project(wip-shooter)
find_package(SDL2 REQUIRED) # Requires at least version 3.0
include_directories(${SDL2_INCLUDE_DIRS})
+
set(CMAKE_C_STANDARD 11) # Requires C11 standard
set (CMAKE_CXX_STANDARD 17)
add_executable(${PROJECT_NAME}
- src/city.c)
+ src/level.c)
+
+target_compile_options(${PROJECT_NAME}
+ PRIVATE "-O3"
+ PRIVATE "-march=native"
+)
target_link_libraries(${PROJECT_NAME} ${SDL2_LIBRARIES})